Exostar ProviderPass Service Issues

Incident Report for Ensora Health

Resolved

Exostar has indicated that the issue is now resolved for both Authy and hardware tokens. They are continuing to monitor the system closely.
Posted Mar 18, 2026 - 10:16 EDT

Update

Exostar has indicated that the issue persists for some users with the Authy app. Please note that the issue should now be resolved for signing via hardware token.
Posted Mar 18, 2026 - 10:00 EDT

Identified

Exostar ProviderPass is continuing to experience signing issues. Some users may be unable to sign using either the Authy app or the hardware tokens. Exostar is urgently working with their partners to resolve the issue.
Posted Mar 17, 2026 - 17:45 EDT
This incident affected: eRx (Exostar EPCS services).