Procentive Performance Issues

Incident Report for Ensora Health

Resolved

We have completed an update to reconcile payer sequence information in Procentive and ensure records are aligned correctly. This update restored payer sequence data using a system snapshot taken at approximately 2:00 AM CT on September 3, 2026, and was completed on September 4, 2026 at 10:15 AM CT.

If your organization made any changes to payer order or sequence for a client between 2:00 AM CT on September 3 and 10:15 AM CT on September 4, those changes may have been reverted by this update and will need to be reviewed and reapplied. Without this review, affected claims could go out with an incorrect payer order, which may lead to rejections or misrouted payments.

If you have questions or need help reviewing records, contact our contact our support team at procentive.support@ensorahealth.com or call 877-288-5583 for assistance.
Posted Sep 04, 2026 - 12:03 EDT

Investigating

We are aware of reports that some users are experiencing performance issues in various areas of the application. Our team is actively investigating and will provide updates as soon as more information becomes available.
Posted Sep 03, 2026 - 11:05 EDT
This incident affected: Procentive (Procentive, Procentive Application).