Exostar ProviderPass Service Issues

Incident Report for Ensora Health

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 13:52 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2026 - 11:17 EDT

Update

Exostar is continuing to investigate an issue that is impacting some Authy users. Those users may not be able to sign scheduled drug prescriptions with the Authy app. Note that the similar issue for hardware tokens has been resolved.
Posted Mar 19, 2026 - 10:03 EDT

Identified

Exostar is continuing to experience issues for some Authy users and is working to resolve the issue.
Posted Mar 18, 2026 - 11:11 EDT
This incident affected: eRx (Exostar EPCS services).