Exostar Registration Issues

Incident Report for Ensora Health

Resolved

This incident has been resolved.
Posted Sep 03, 2026 - 21:17 EDT

Identified

We will be applying a hotfix to address the Exostar registration issues at 9pm Central time 9/3/2026.
Posted Sep 03, 2026 - 11:36 EDT

Investigating

We are currently investigating an issue with Exostar EPCS registrations. Some users may be unable to order an Exostar hardware token. Please use the Report Bug feature if you encounter an issue with registration. Note that this issue is not affecting EPCS signing, and is not affecting ID.me systems.
Posted Sep 01, 2026 - 16:00 EDT
This incident affected: eRx (Exostar EPCS services).